CVE-2026-61781
CRITICAL(9.9)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CVSS 9.9 — Kritisch
Erwähnungen (letzte 60 Tage)
EPSS-Score
0.8%
Exploit-Wahrscheinlichkeit (30 Tage)
CVSS Score
9.9
Technische Schwere
SecBoard-Einordnung
CVE-2026-61781 betrifft die PostgreSQL-Erweiterung pg_partman vor Version 5.5.0. Eine Schwachstelle in der Funktion create_partition_time() ermöglicht es einem Angreifer mit partman_user-Privilegien, SQL-Code in die Konfiguration einzuschleusen. Dieser Code wird später vom pg_partman_bgw-Worker mit Superuser-Rechten ausgeführt, was zu einer vollständigen Kompromittierung der Datenbank und der Ausführung von Betriebssystembefehlen führen kann. Die Schwachstelle ist mit einem CVSS-Score von 9.9 als kritisch eingestuft, was auf ein extrem hohes Risiko hinweist. Obwohl die EPSS-Wahrscheinlichkeit für eine Ausnutzung derzeit bei nur 1% liegt und die Schwachstelle nicht im CISA KEV-Katalog aufgeführt ist, ist das Potenzial für schwerwiegende Auswirkungen erheblich. Security-Teams sollten umgehend alle Instanzen von pg_partman auf Version 5.5.0 oder höher aktualisieren, um diese kritische Schwachstelle zu beheben. Eine schnelle Patch-Implementierung ist aufgrund der potenziellen weitreichenden Folgen und der Möglichkeit der persistenten Wiederherstellung des Zugriffs dringend empfohlen.
KI-gestützte Einordnung auf Basis der NVD-Daten.
Beschreibung
pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, create_partition_time() reads the writable part_config.time_encoder text value and interpolates it without identifier quoting into a dynamically executed SELECT statement. A role with the documented partman_user INSERT and UPDATE privileges can store SQL rather than a function name. When pg_partman_bgw later creates a child partition for a text- or UUID-keyed set, the worker executes the stored SQL with pg_partman_bgw.role privileges, which default to PostgreSQL superuser. The persistent configuration row can repeatedly restore elevated access on later maintenance ticks, and successful exploitation can permit database-wide compromise and operating-system command execution as the PostgreSQL service account. This issue is fixed in version 5.5.0.