SecBoard
Zurück zur CVE-Übersicht

CVE-2026-39892

CRITICAL(9.8)

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Risk Signal Score25/100 — MITTEL
  • CVSS 9.8 — Kritisch

Erwähnungen (letzte 60 Tage)

Artikel

EPSS-Score

0.7%

Exploit-Wahrscheinlichkeit (30 Tage)

CVSS Score

9.8

Technische Schwere

SecBoard-Einordnung

Die Schwachstelle CVE-2026-39892 betrifft das Python-Paket cryptography in Versionen vor 46.0.7. Es handelt sich um einen Pufferüberlauf, der auftreten kann, wenn nicht-zusammenhängende Puffer an bestimmte APIs wie Hash.update() übergeben werden. Dies könnte potenziell zu unautorisiertem Speicherzugriff oder Abstürzen führen. Die Schwachstelle wird mit einem CVSS-Score von 9.8 als kritisch eingestuft, was auf ein hohes Risiko hinweist. Die Exploit-Wahrscheinlichkeit () liegt jedoch bei nur 1%, und die Schwachstelle ist derzeit nicht im KEV-Katalog für aktiv ausgenutzte Schwachstellen gelistet. Security-Teams sollten die betroffenen cryptography-Installationen umgehend auf Version 46.0.7 oder höher aktualisieren, um das Risiko zu minimieren. Obwohl die aktive Ausnutzung unwahrscheinlich erscheint, ist aufgrund der Kritikalität ein schnelles Handeln ratsam.

KI-gestützte Einordnung auf Basis der NVD-Daten.

Beschreibung

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. From 45.0.0 to before 46.0.7, if a non-contiguous buffer was passed to APIs which accepted Python buffers (e.g. Hash.update()), this could lead to buffer overflows. This vulnerability is fixed in 46.0.7.

Betroffene Produkte

  • cpe:2.3:a:cryptography.io:cryptography:*:*:*:*:*:python:*:*

GitHub Advisories

GHSA-p423-j2cm-9vmqMEDIUM

Cryptography vulnerable to buffer overflow if non-contiguous buffers were passed to APIs

pip/cryptography→ 46.0.7
GitHub Advisory

Referenzen