SecBoard
Zurück zur CVE-Übersicht

CVE-2026-33557

CRITICAL(9.1)

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Risk Signal Score23/100 — NIEDRIG
  • CVSS 9.1 — Kritisch

Erwähnungen (letzte 60 Tage)

Artikel

EPSS-Score

0.9%

Exploit-Wahrscheinlichkeit (30 Tage)

CVSS Score

9.1

Technische Schwere

SecBoard-Einordnung

CVE-2026-33557 betrifft Apache Kafka und stellt eine kritische Authentifizierungsschwachstelle dar. Standardmäßig akzeptiert der Broker JWT-Tokens ohne Signatur-, Aussteller- oder Zielgruppenvalidierung. Dies ermöglicht es einem Angreifer, gefälschte JWT-Tokens zu erstellen und sich als beliebiger Benutzer auszugeben, was zu unautorisiertem Zugriff führt. Die Schwachstelle betrifft Kafka-Versionen 4.1.0 und 4.1.1. Mit einem CVSS-Score von 9.1 (CRITICAL) ist die Schwachstelle als hochkritisch einzustufen. Obwohl die EPSS-Wahrscheinlichkeit mit 1% niedrig ist und die Schwachstelle nicht in gelistet ist, deutet die Art des Fehlers auf ein erhebliches Risiko hin, da die Authentifizierung umgangen werden kann. Security-Teams sollten umgehend handeln. Für betroffene Kafka-Versionen 4.1.0 und 4.1.1 muss die Konfiguration sasl.oauthbearer.jwt.validator.class explizit auf org.apache.kafka.common.security.oauthbearer.BrokerJwtValidator gesetzt werden. Alternativ ist ein Upgrade auf Kafka v4.1.2, v4.2.0 oder neuere Versionen empfohlen, da diese das Problem beheben.

KI-gestützte Einordnung auf Basis der NVD-Daten.

Beschreibung

A possible security vulnerability has been identified in Apache Kafka. By default, the broker property `sasl.oauthbearer.jwt.validator.class` is set to `org.apache.kafka.common.security.oauthbearer.DefaultJwtValidator`. It accepts any JWT token without validating its signature, issuer, or audience. An attacker can generate a JWT token from any issuer with the `preferred_username` set to any user, and the broker will accept it. We advise the Kafka users using kafka v4.1.0 or v4.1.1 to set the config `sasl.oauthbearer.jwt.validator.class` to `org.apache.kafka.common.security.oauthbearer.BrokerJwtValidator` explicitly to avoid this vulnerability. Since Kafka v4.1.2 and v4.2.0 and later, the issue is fixed and will correctly validate the JWT token.

Betroffene Produkte

  • cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:*

Referenzen