SecBoard
Zurück zur CVE-Übersicht

CVE-2025-68613

CRITICAL(9.9)KEV — Aktiv ausgenutzt

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Risk Signal Score84/100 — KRITISCH
  • CVSS 9.9 — Kritisch
  • EPSS 99% — sehr wahrscheinlich ausgenutzt
  • Im CISA KEV-Katalog (aktiv ausgenutzt)

CISA KEV

Bestätigt ausgenutzt

EPSS-Score

99.0%

Exploit-Wahrscheinlichkeit (30 Tage)

CVSS Score

9.9

Technische Schwere

SecBoard-Einordnung

Die Schwachstelle CVE-2025-68613 betrifft die Open-Source-Workflow-Automatisierungsplattform n8n und ist eine kritische ()-Schwachstelle. Sie ermöglicht es authentifizierten Angreifern, beliebigen Code mit den Privilegien des n8n-Prozesses auszuführen, indem sie das Workflow-Ausdrucksauswertungssystem missbrauchen. Dies kann zu einer vollständigen Kompromittierung der Instanz führen, einschließlich unbefugtem Datenzugriff und Systemoperationen. Die Schwachstelle ist in n8n-Versionen ab 0.211.0 bis einschließlich 1.120.3, 1.121.0 und 1.121.x (vor 1.121.1) vorhanden. Mit einem CVSS-Score von 9.9 (CRITICAL) und einer EPSS-Wahrscheinlichkeit von 99% ist diese Schwachstelle extrem kritisch. Die Tatsache, dass sie aktiv ausgenutzt wird und im KEV-Katalog aufgeführt ist, unterstreicht die Dringlichkeit der Behebung. Authentifizierte Angreifer können die volle Kontrolle über betroffene n8n-Instanzen erlangen, was ein erhebliches Risiko darstellt. Security-Teams sollten umgehend auf die gepatchten n8n-Versionen 1.120.4, 1.121.1 oder 1.122.0 aktualisieren. Falls ein sofortiges Upgrade nicht möglich ist, sollten temporäre Maßnahmen wie die Beschränkung der Workflow-Erstellungs- und Bearbeitungsberechtigungen auf vertrauenswürdige Benutzer sowie der Einsatz von n8n in einer gehärteten Umgebung in Betracht gezogen werden. Diese Workarounds mindern das Risiko, eliminieren es jedoch nicht vollständig und sollten nur kurzfristig angewendet werden.

KI-gestützte Einordnung auf Basis der NVD-Daten.

Beschreibung

n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.

Betroffene Produkte

  • cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:*
  • cpe:2.3:a:n8n:n8n:1.121.0:*:*:*:*:node.js:*:*

Referenzen