CVE-2025-55754
CRITICAL(9.6)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CVSS 9.6 — Kritisch
Erwähnungen (letzte 60 Tage)
EPSS-Score
10.3%
Exploit-Wahrscheinlichkeit (30 Tage)
CVSS Score
9.6
Technische Schwere
SecBoard-Einordnung
Die Schwachstelle CVE-2025-55754 betrifft Apache Tomcat und resultiert aus einer unzureichenden Neutralisierung von ANSI-Escape-Sequenzen in Log-Nachrichten. Auf Windows-Systemen mit Konsolenunterstützung für ANSI-Sequenzen könnte ein Angreifer durch eine speziell präparierte URL Konsolen und die Zwischenablage manipulieren, um Administratoren zur Ausführung bösartiger Befehle zu verleiten. Obwohl kein direkter Angriffsvektor identifiziert wurde, ist ein ähnlicher Angriff auf anderen Betriebssystemen nicht auszuschließen. Mit einem CVSS-Score von 9.6 (CRITICAL) wird diese Schwachstelle als hochkritisch eingestuft, obwohl die EPSS-Wahrscheinlichkeit für eine Ausnutzung bei moderaten 10 % liegt und sie nicht in CISAs Known Exploited Vulnerabilities (KEV) Katalog aufgeführt ist. Die potenzielle Manipulation von Konsolen und die Möglichkeit, Administratoren zur Ausführung von Befehlen zu bewegen, unterstreichen das hohe Risiko. Security-Teams sollten umgehend ein Upgrade auf Apache Tomcat Version 11.0.11 oder höher, 10.1.45 oder höher, oder 9.0.109 oder höher durchführen, um diese Schwachstelle zu beheben. Betroffen sind die Versionen 11.0.0-M1 bis 11.0.10, 10.1.0-M1 bis 10.1.44 und 9.0.40 bis 9.0.108, sowie ältere EOL-Versionen wie 8.5.60 bis 8.5.100. Eine schnelle Patch-Implementierung ist zur Risikominimierung unerlässlich.
KI-gestützte Einordnung auf Basis der NVD-Daten.
Beschreibung
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Erkennung & Indikatoren
Ausnutzung
In den geprüften Quellen nicht genannt
Behobene Versionen
- 11.0.11 or later
- 10.1.45 or later
- 9.0.109 or later
- V5.0 or later
Threat-Hunting-Queries
Sentinel/Defender KQL
DeviceProcessEvents
| where InitiatingProcessCommandLine contains "Tomcat" and ProcessCommandLine contains "ANSI escape sequence"Splunk SPL
index=* sourcetype=apache:tomcat | search "ANSI escape sequence"Sigma
title: Apache Tomcat ANSI Escape Sequence Injection
logsource:
category: process_creation
product: windows
detection:
selection:
ParentImage|endswith: '\Tomcat\bin\tomcat.exe'
CommandLine|contains: 'ANSI escape sequence'
condition: selectionElastic ES|QL
from process where process.parent.executable : "*Tomcat*" and process.args : "*ANSI escape sequence*"SecBoard-generated · behavioral · requires customization — Von SecBoard erzeugt und nicht in einer Zielumgebung validiert. Vor dem Einsatz an die eigene Protokollierung anpassen.
Betroffene Produkte
- cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
- cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
- cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
- cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
- cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
GitHub Advisories
Apache Tomcat Vulnerable to Improper Neutralization of Escape, Meta, or Control Sequences