SecBoard
Zurück zur CVE-Übersicht

CVE-2025-55752

HIGH(7.5)

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Risk Signal Score38/100 — MITTEL
  • CVSS 7.5 — Hoch
  • EPSS 64%

Erwähnungen (letzte 60 Tage)

Artikel

EPSS-Score

64.4%

Exploit-Wahrscheinlichkeit (30 Tage)

CVSS Score

7.5

Technische Schwere

SecBoard-Einordnung

CVE-2025-55752 beschreibt eine Relative Path Traversal Schwachstelle in Apache Tomcat. Diese Regression ermöglicht es Angreifern, durch Manipulation der Request URI Sicherheitsbeschränkungen zu umgehen, einschließlich des Zugriffs auf /WEB-INF/ und /META-INF/. Unter bestimmten Umständen, insbesondere wenn PUT-Anfragen aktiviert sind, könnte dies zu führen, obwohl dies als unwahrscheinlich gilt. Die Schwachstelle wird mit einem CVSS-Score von 7.5 (HIGH) bewertet und hat eine EPSS-Wahrscheinlichkeit von 64 % für eine Ausnutzung, was auf ein erhöhtes Risiko hindeutet. Obwohl sie derzeit nicht in der KEV-Liste aufgeführt ist, erfordert die hohe EPSS-Bewertung eine proaktive Betrachtung. Die Möglichkeit, Sicherheitsbeschränkungen zu umgehen, ist kritisch. Security-Teams sollten umgehend ein Upgrade auf Apache Tomcat Version 11.0.11 oder höher, 10.1.45 oder höher oder 9.0.109 oder höher durchführen, um diese Schwachstelle zu beheben. Es wird empfohlen, die Konfiguration auf aktivierte PUT-Anfragen zu überprüfen und diese bei Bedarf einzuschränken, um das Risiko weiter zu minimieren.

KI-gestützte Einordnung auf Basis der NVD-Daten.

Beschreibung

Relative Path Traversal vulnerability in Apache Tomcat. The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

Betroffene Produkte

  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:-:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone11:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone12:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone13:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone14:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone15:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone16:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone17:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone18:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone19:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone20:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone21:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone22:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone23:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:9.0.0:milestone24:*:*:*:*:*:*

GitHub Advisories

GHSA-wmwf-9ccg-fff5HIGH

Apache Tomcat Vulnerable to Relative Path Traversal

maven/org.apache.tomcat:tomcat→ 11.0.11
GitHub Advisory

Referenzen