SecBoard
Zurück zur CVE-Übersicht

CVE-2024-50379

CRITICAL(9.8)

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Risk Signal Score34/100 — MITTEL
  • CVSS 9.8 — Kritisch
  • EPSS 32%

Erwähnungen (letzte 60 Tage)

Artikel

EPSS-Score

31.8%

Exploit-Wahrscheinlichkeit (30 Tage)

CVSS Score

9.8

Technische Schwere

SecBoard-Einordnung

CVE-2024-50379 betrifft Apache Tomcat und ist eine Time-of-check Time-of-use (TOCTOU) Race Condition Schwachstelle während der JSP-Kompilierung. Diese kann unter bestimmten Bedingungen zu einer () führen, insbesondere auf Dateisystemen, die nicht zwischen Groß- und Kleinschreibung unterscheiden, wenn das Standard-Servlet für Schreibvorgänge aktiviert ist (nicht-Standardkonfiguration). Betroffen sind die Versionen 11.0.0-M1 bis 11.0.1, 10.1.0-M1 bis 10.1.33 und 9.0.0.M1 bis 9.0.97. Auch ältere, EOL-Versionen wie 8.5.0 bis 8.5.100 sind betroffen. Die Schwachstelle wird mit einem CVSS-Score von 9.8 als kritisch eingestuft, was auf ein hohes potenzielles Risiko hinweist. Die Prediction Scoring System ()-Wahrscheinlichkeit liegt bei 32%, was eine erhöhte Wahrscheinlichkeit einer Ausnutzung signalisiert, obwohl die Schwachstelle derzeit nicht in 's () Katalog aufgeführt ist. Security-Teams sollten umgehend ein Upgrade auf Apache Tomcat Version 11.0.2, 10.1.34 oder 9.0.98 durchführen, um das Problem zu beheben. Eine Priorisierung dieser Maßnahme ist aufgrund der Kritikalität und der potenziellen RCE-Möglichkeit dringend empfohlen.

KI-gestützte Einordnung auf Basis der NVD-Daten.

Beschreibung

Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability during JSP compilation in Apache Tomcat permits an RCE on case insensitive file systems when the default servlet is enabled for write (non-default configuration). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.0.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.

Betroffene Produkte

  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
  • cpe:2.3:o:netapp:bootstrap_os:-:*:*:*:*:*:*:*

Referenzen